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1. Introduction 

AuditSampler is a statistical sampling and data analytics software which enables efficient and 
effective audits based on statistical methods and the auditing standards (ISA/AU-C 530, ISA 
315). Easy-to-use audit tool to calculate the sample size, select samples and evaluate the 
results for Attributes Sampling, Monetary Unit Sampling (MUS) and Classical Variables 
Sampling (CVS). 
 
The confidence level, tolerable error and expected error can be quantified to determine the 
required sample size and statistically evaluate the results. Samples can be selected based on 
random, systematic, cell and value-weighted selection methods. 
 
Query and filter data for exception reporting and analysis. Chart the analysis using graphs. 
Histogram and boxplot graphs to display the data distribution and detect outliers. 
 
AuditSampler is a Windows desktop application. Multiple windows can be open for multitasking. 
A temporary SQLite table is created for each user session to query the data and the temporary 
table is automatically dropped or deleted when that session ends. The application does not 
store any data. 
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2. Installation 

2.1 System Requirements 

Operating systems: Windows 10, 11 (64-bit), Windows Server 2019 

Memory: 4GB RAM or more 

2.2 Register and Install License Key 

 
 

i. Right-click on the AuditSampler-3.0-x64.exe file and select “Run as administrator”. 

ii. Select if you want to install for only you or all users (requires administrator privileges). 

iii. Read and accept the license agreement. 

iv. You will be prompted, "The license is not activated. Would you like to Register now". Click 
"Yes" to register immediately. 

v. At the "Register License Key" screen, enter your name, company/organization and the 
licence key (case sensitive). Click “OK” to activate. 

 

 

2.3 Update License Key 

To update or enter a new license key after expiry, right-click the AuditSampler program icon or 
shortcut and select “Run as administrator”. From the Help menu, select Registration Information 
and click on the link Register License Key. Enter your details and the new license key. 

 

2.4 Uninstall License Key 

To uninstall and delete the license key if no longer in use, right-click the AuditSampler program 
icon or shortcut and select “Run as administrator”. From the Help menu, select Registration 
Information and click on the link Uninstall License Key. Select OK to confirm or Cancel. 
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3. File 

3.1 Import Data 

Data can be imported from Excel, Csv/Txt and SQLite files. Import up to 20 million rows and 30 
columns. 

• Excel workbook (.xlsx) 

• Csv comma delimited (.csv) 

• Text tab delimited (.txt) 

• SQLite database (.db) 

 
Column name requirements 

All files must have a header row that contains names for each of the columns. The column 
names must meet the data table requirements: 

• No special characters such as % . , - & / \ : ; ( ) * % #. 

• Does not start with a number. 

• Contain only alphanumeric characters and the underscore character “_”. 

When the file is imported, any special characters are automatically removed and spaces are 
replaced with an underscore. 

 
File > Import Data 
 

 
 
Select Table/Sheet to list the columns in the box. Select up to 30 columns. The Scan setting is 
to enable automatic detection of the column data types for Excel, Csv and Text files. Scan up to 
the first 200 rows in the file to detect the column type. 
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3.2 Export Data 

Data imported into AuditSampler can be exported and saved as Excel workbook (.xlsx), Csv 
comma delimited (.csv) and SQLite database (.db) files. 
 

File > Export Data or right click in the gridview 
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Large datasets (> 1 million rows) can be saved as tables in a SQLite database file for efficient 
access and reuse. 
 

File > Export Data > SQLite Database 
 

 
 
- Create Tablename (specify a new table name). 
- Select New or Existing database file. 
 

3.3 Join Tables 

Join two tables in the SQLite database file that have a common column (e.g. Cust_No). Return 
all rows in the Left Table with matching values in the Right Table. 
 
File > Import Data > Join Tables (*.db) 
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3.4 Save/Print Results 

The sample selection results can be saved as Excel workbook (.xlsx), Csv comma delimited 
(.csv) and PDF (.pdf) files. The results can also be output to printer or copy/paste to Excel and 
Word. 
 

File > Save Sampling or bottom toolbar options or right click in the gridview 
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4. Edit 

4.1 Datetime Display 

Select the datetime display format. The default is Short Date (e.g. MM/dd/yy) or change to Full 
Datetime (yyyy/MM/dd HH:mm:ss AM/PM). 
 
Edit > Datetime Display 
 

 
 

4.2 Delete Table 

Delete a table in the SQLite database file. 
 

Edit > SQLite Database > Delete Table 
 

 
 

4.3 Rename Table 

Rename a table in the SQLite database file. 
 
Edit > SQLite Database > Rename Table 
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4.4 Modify Table 

Change the column type in the SQLite database table. 
 
Edit > SQLite Database > Modify Table 
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5. Data 

 
 

5.1 Query Filter/Sort 

Data can be query and filtered on Numeric/Text/Date columns with the following operators. In 
SQL queries, datetime and text strings must be enclosed within a pair of single quotes: 
 

Operator Description Criteria 

> Greater than Amount > 5000 

Inv_Date > '2017-03-28 00:00:00' 

< Less than Amount < 500 

Inv_Date < '2017-03-28 00:00:00' 

>= Greater than or equal to Amount >= 5000 

Inv_Date >= '2017-03-28 00:00:00' 

<= Less than or equal to Amount <= 500 

Inv_Date <= '2017-03-28 00:00:00' 

= Equal to Item_Code = 3 

City = ‘Boston’ 

Inv_Date = '2017-03-28 00:00:00' 

!= Not equal to Item_Code != 3 

City != ‘Boston’ 

Inv_Date != '2017-03-28 00:00:00' 

Like Specific pattern in values Cust_No Like '23%' 

Cust_No Like '%23' 

In List of values Item_Code In (1, 3, 5) 
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City In ('Boston', 'New York', 'Miami') 

Between Range of values Amount Between 3000 And 5000 

Inv_Date Between '2017-01-01' And 
'2017-06-30' 

And Filter more than one condition Item_Code = 3 And Unit_Price != 4.25 

Inv_Date Between '2017-01-01' And 
'2017-06-30' And Amount > 5000 

Or Filter more than one condition Amount = 0 Or Amount = '' 

Qty > 100 Or Amount > 5000 

 
Select the column, specify the operator/condition and enter the value to filter. The filter criteria 
can also be typed directly into the filter expression box. 
 

Data > Query Filter Records 
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For Date columns the value must be in the datetime format ‘yyyy-mm-dd 00:00:00’ together 
with the opening and closing single quotes. 
 

 
 
The query can be Sort By column, Asc (Ascending) or Desc (Descending). Select the column 
and specify the sort order. The sort criteria can also be typed directly into the sort expression 
box. 
 
Data > Sort Records 
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5.2 Top 10 Records 

Filter and display the Top or Bottom 10 records. 
 

Data > Top 10 Records 
 

 
 

5.3 Statistics 

Statistics and aggregate functions on numeric/value columns: Count (negative/zero/blank 
values), Sum (total value), Min (minimum value), Max (maximum value), Avg (average value), 
Stdev (standard deviation), Z-score (+/- 3 standard deviations from the mean) and Skewness 
(positive right-skewed or negative left-skewed). The further the skew value is from zero, the 
greater the skew. 
 

Data > Statistics 
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5.4 Box Plot 

A boxplot (box and whisker plot) displays the center and spread of a data set based on quartiles 
and the five-number summary which consists of: the minimum value, lower quartile, median, 
upper quartile and the maximum value. It can identify outlying values (Outliers) that are very far 
away from the quartiles and the other values in the data. 
 

Data > Box Plot 
 

 
 

 
 

• Min: Minimum (lowest value excluding outliers). 

• Q1: Lower Quartile (25th percentile). 
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• Med: Median value (50th percentile). 

• Q3: Upper Quartile (75th percentile). 

• Max: Maximum (highest value excluding outliers). 

 

A boxplot displays a “box” with the bottom as the lower quartile (Q1), the middle as the median 
(Q2) and the top as the upper quartile (Q3). The “whiskers” are the lines that extend from the 
box to the minimum and maximum values (excluding outliers). Extreme values that fall outside 
the whiskers are designated Outliers and marked as dots in the boxplot. 
 
The boxplot divides the data into 4 equal parts (quartile). The lower whisker represents the 
bottom 25% of the data, the lower half of the “box” represents the second 25%, the upper half of 
the “box” represents the third 25% and the upper whisker represents the top 25%. 
 
Lower Quartile (Q1): The first quartile or 25th percentile1. The bottom 25% of the data fall 
below this value. 
 
Median (Q2): The second quartile or 50th percentile2. The mid-point of the data shown by the 
dashed line that divides the “box” into two parts. 50% of the data fall below this value and 50% 
are above. 
 
Upper Quartile (Q3): The third quartile or 75th percentile3. 75% of the data fall below this value 
and the top 25% are above.  
 
Interquartile Range (IQR): The range between the lower and upper quartiles (Q3 - Q1) is 
called the interquartile range and is the highlighted “box” area which represents the middle 50% 
of data. 
 
Lower Whisker: The whisker line that extends below the lower quartile to the minimum value 
and represents the bottom 25% of data. 
 
Upper Whisker: The whisker line that extends above the upper quartile to the maximum value 
and represents the top 25% of data. 
 
Minimum (Min): The lowest value that is within 1.5*IQR below the lower quartile (Q1 - 1.5*IQR) 
excluding outliers and represents the lower whisker limit. 
 
Maximum (Max): The highest value that is within 1.5*IQR above the upper quartile (Q3 + 
1.5*IQR) excluding outliers and represents the upper whisker limit. 
 
Outliers: An extreme value that lies outside the lower or upper whiskers is designated an 
“Outlier”. A value less than (Q1 – 1.5*IQR) or greater than (Q3 + 1.5*IQR) is considered a mild 
outlier. A value less than (Q1 – 3*IQR) or greater than (Q3 + 3*IQR) is considered an extreme 
outlier. 
 
1 25th percentile = .25(N + 1)th data point. 
2 50th percentile = .50(N + 1)th data point. 
3 75th percentile = .75(N + 1)th data point. 
* N = number of values in the data set (sorted from smallest to largest). 

 

5.5 Histogram 

A histogram displays the distribution of a data set by dividing the values into value ranges or 
intervals and is similar in appearance to a column chart. It can show the frequency of 
occurrence for each range of values. 
 

Data > Histogram 
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* Range: >= Lower Limit and < Upper Limit. 
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5.6 Add Column 

Add a calculated column to the data table. Enter the column name and column type. Type Real 
is for double/decimal values. 
 

Data > Add Column 
 

 
 

5.7 Delete Column 

Delete a column from the data table. 
 

Data > Delete Column 
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5.8 Move Column 

Move and change the column position up or down in the data table. 
 

Data > Move Column 
 

 
 

5.9 Rename Column 

Rename and change the column name in the data table. 
 

Data > Rename Column 
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6. Analysis 

 
 

6.1 Summarization 

Summarize and group records. Select the Group By column and Total On column. Options to 
specify Statistics (Avg, Min, Max), Filter, Sort By (Descending or Ascending) and Limit (rows to 
display). 
 

Analysis > Summarization 
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6.2 Group By Date 

Summarize and group records by date. Select group by Day, Week, Month or Year. Select the 
Date column, Total On column, month and year. 

 
Analysis > Group By Date 
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6.3 Stratification 

Stratify records based on value ranges (intervals). Select the column to stratify and specify the 
range using intervals, increment, list or strata options. Strata to determine the optimal 
boundaries based on the cumulative square root of frequency. 
 

Analysis > Stratification 
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* Range: >= Lower Limit and < Upper Limit. 
 

For the List of intervals option, specify the start value of each interval and the end value of the 
last interval in the textbox (one per line): 
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For the Strata option, specify the number of strata, cells and optionally the top/bottom stratum  
cutoff values. 
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6.4 Aging 

Age outstanding records based on the due date. Select the Due Date column, Total On column 
and the report date. 
 

Analysis > Aging 
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6.5 Outliers 

Select the Value column and the outlier method, Interquartile Range (IQR) or Z-Score. The 
upper and lower limits for IQR can be set at 1.5*IQR, 1.7*IQR or 3*IQR. The upper and lower 
limits for Z-Score can be set from 2.0 to 5. 
 

Analysis > Outliers 
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6.6 Chart Analysis 

Select the chart type (Column, Histogram, Line, Scatter, Pie, Doughnut), X-axis and Y-axis. 
Define the chart and axis titles. 
 

Analysis > Chart Analysis 
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6.7 Duplicates 

Select one or more columns to check for duplicate entries or values. 
 

Analysis > Duplicates 
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6.8 Sequence Gaps 

Select a numeric column to check for gaps in the number sequence. 
 

Analysis > Sequence Gaps 
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7. Attributes Sampling 

 
 

7.1 Sample Size 

Sampling > Attributes > Calculate Sample Size 
 

 
 

Sample size can be calculated based on Binomial, Hypergeometric or Poisson distributions. 
 

Input Values Description 
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Expected Error Rate (%) Expected rate of error in the population. From 0.00 to 18%. 

Tolerable Error Rate (%) Maximum acceptable rate of error in the population. From 2% 
to 20%. 

Confidence Level (%) The required level of assurance (1 - risk of incorrect 
acceptance). From 50 to 99%.  

Population Size 
(Hypergeometric only) 

Population size from 100 to 8 Million. 

 
Results Description 

Number of Expected Errors Expected number of errors in the sample. 

Required Sample Size Calculated number of items or records to sample. Maximum 
size is 3000. 

 

7.2 Select Sample 

Samples can be selected based on Systematic, Random or Cell selection methods. 

Parameters Description 

Systematic Based on a sampling interval which is calculated by dividing the number 
of items in the population with the sample size. A random start between 
1 and the sampling interval is selected as the first sample. Subsequently, 
every nth item in the population which equals each increment of the 
sampling interval is selected. 

Random Random numbers between 1 and the total population size are picked as 
the selected items. The samples are the items in the population that 
match the selected random numbers. 

Cell Based on a cell interval which is used to divide the population into cells 
of equal size and a random number is picked from each cell as the 
sample item. The cell interval is calculated by dividing the number of 
items in the population with the sample size. 

Sample Size Number of samples to select. Maximum size is 3000. 

Random Seed A random seed value is used to generate the random values for the 
sample selection. The seed for a previous sample can be used to 
recalculate the same results for that sample. 

 

Sampling > Attributes > Select Sample 
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7.3 Evaluate Results 

Sampling > Attributes > Evaluate Results 
 

 
 

Sample results can be evaluated based on Binomial, Hypergeometric or Poisson distributions. 
 
The results are evaluated by comparing the Upper Error Limit (UEL) to the Tolerable Error Rate 
(TER). The upper error limit equals the sample error rate plus an allowance for sampling risk. 

◼ If UEL  TER, the sample results indicate that the controls are effective. 

◼ If UEL  TER, the sample results indicate that the controls are not effective. 

 
Input Values Description 

Sample Size Number of samples selected. Maximum size is 3000. 

Number Errors in Sample Number of errors found in the samples selected. 

Confidence Level (%) The required level of assurance (1 - risk of incorrect 
acceptance). From 50 to 99%. 

Tolerable Error Rate (%) Maximum acceptable rate of error for the sample results. 
From 2 to 20%. 

Population Size 
(Hypergeometric only) 

Population size from 100 to 8 Million. 

 
Results Description 

Sample Error Rate (%) The percentage of errors detected in the sample size. 

Allowance for Sampling 
Risk (%) 

The allowance for projection of the sample errors to the 
population. 

Upper Error Limit (%) The sample error rate plus an allowance for sampling risk. 
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8. Monetary Unit Sampling (MUS) 

 
 

8.1 Sample Size 

Sampling > MUS > Calculate Sample Size 
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The MUS sample size is calculated based on the formula n = R/P, which is derived from the 
Poisson probability distribution: where n is the sample size, R is the reliability factor (confidence 
factor) and P is the precision (tolerable misstatement rate). 
 

Input Values Description 

Population Value Book value or monetary value of the population. Maximum 
value of 2000 Million. 

Tolerable Misstatement Maximum acceptable amount of monetary misstatement in 
the population. Maximum limit is 50% of population value. 

Expected Misstatement Expected amount of monetary misstatement in the 
population. Maximum limit is 60% of tolerable misstatement. 

Confidence Level (%) The required level of assurance (1 - risk of incorrect 
acceptance). From 10 to 99%. 

 
Results Description 

Tolerable Misstatement % The tolerable misstatement divided by the population value. 

Expected Misstatement % The expected misstatement divided by the population value. 

Ratio Expected/Tolerable The expected misstatement divided by the tolerable 
misstatement. 

Confidence Factor The reliability factor that reflects the confidence level and the 
expected amount of misstatement. 

Required Sample Size The calculated number of monetary units to sample. 
Maximum size is 5000. 

Sampling Interval The population value divided by sample size. Interval used to 
systematically select the sample items. 

Expected Sum of Taints The expected misstatement (%) multiplied by the sample 
size. 

 

8.2 Select Sample 

Samples can be selected based on Systematic, Random or Cell selection methods. 

Parameters Description 

Systematic Based on a sampling interval which is calculated by dividing the 
population value with the sample size. A random start between $1 and 
the sampling interval is selected as the first sampling unit. Each amount 
in the population is added to a cumulative subtotal. The first amount 
whose balance results in the subtotal equalling or exceeding the random 
start is selected as the first sample. Subsequently, each amount which 
causes the subtotal to equal or exceed each increment of the sampling 
interval is selected. 

Random Random values between $1 and the total population value are picked as 
the selected dollar units. The samples are the amount balances in the 
population that contain the selected dollar units. 

Cell Based on a cell interval which is calculated by dividing the population 
value with the sample size. The cell interval is used to divide the 
population value into cells of equal size and a random value is picked 
from each cell as the selected dollar unit. The samples are the amount 
balances in the population that contain the selected dollar units. 
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Sample On The monetary amount column to sample on. 

Sample Size The number of samples to select. Maximum size is 5000. 

Random Seed A random seed value is used to generate the random values for the 
sample selection. The seed for a previous sample can be used to 
recalculate the same results for that sample. 

 

Sampling > MUS > Select Sample 
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8.3 Evaluate Results 

Sampling > MUS > Evaluate Results 
 

 
 

The sample results are evaluated by comparing the Upper Misstatement Bound (UMB) and 
Lower Misstatement Bound (LMB) to the Tolerable Misstatement (TM). The upper and lower 
misstatement bound equals the upper error limit for overstatements and understatements. 
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◼ If UMB and LMB  TM, the sample results indicate that the account balance is not materially 
misstated. 

◼ If UMB or LMB  TM, the sample results indicate that the account balance is materially 
misstated. 

 
Input Values Description 

Population Value Book value or monetary value of the population. Maximum value 
of 2000 Million. 

Tolerable Misstatement Maximum acceptable amount of misstatement for the sample 
results. Maximum limit is 50% of population value. 

Sample Size The number of samples selected. Maximum size is 5000. 

Confidence Level (%) The required level of assurance (1 - risk of incorrect acceptance). 
From 10 to 99%. 

Misstatements Sample items with a difference between the book value and the 
audited value (overstatement or understatement). Maximum 
number of misstatements is 50. 

 
Results Description 

Tainting % The misstatement amount divided by the sample item's book 
value. A tainting % is calculated for each misstatement if its book 
value is less than the sampling interval. If the book value is 
greater than the sampling interval, the projected misstatement 
and bound will equal the error/misstatement amount. 

Sampling Interval The population value divided by sample size. 

Projected Misstatement The tainting % multiplied with the sampling interval. 

Incremental Confidence 
Factor 

The incremental change in the confidence factor for each 
misstatement, e.g. the increment in the confidence factor from 
misstatement #1 to #2. 

Misstatement Bound The projected misstatement multiplied by the incremental 
confidence factor. 

Upper Misstatement 
Bound 

Total overstatement bound (basic precision + misstatement 
bound for each overstatement) less any projected 
understatement. 

Lower Misstatement 
Bound 

Total understatement bound (basic precision + misstatement 
bound for each understatement) less any projected 
overstatement. 
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9. Classical Variables Sampling (CVS) 

 
 
Classical Variables Sampling (CVS) is used to estimate the total audited amount or the total 
misstatement of a population. Each amount or item in the population is a sampling unit and the 
population is stratified by value for random sampling. CVS uses the normal distribution theory, 
standard deviation and confidence interval to evaluate the characteristics of the population. 

9.1 Sample Size and Selection 

Sampling > CVS > Sample Size and Selection 
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The sample size can be calculated based on stratified difference, ratio or mean estimation. The 
stratum boundaries or intervals for the stratification are determined using the cumulative square 
root of frequency method. The sample size is allocated to the strata using either the optimum 
Neyman allocation or proportional to the stratum total value. 
 
Note: The sample size must be greater than the number of strata (e.g. number of strata = 5, 
sample size > 5). 

 
Input Values Description 

Book Value Book value column to select for sampling. 

Sampling Method Estimation method to compute sample size (difference, ratio 
or mean-per-unit estimation). 

Allocation Allocation of sample size based on the Optimal (Neyman) 
method or Proportional to Total Value. 

Population Value Book value or monetary value of the population. Maximum 
value of 2000 Million. 

Population Size Total number of  items in the population  

Minimum Value Minimum value of the recorded amounts in the population. 

Maximum Value Maximum value of the recorded amounts in the population. 

Number of Strata Number of intervals for the stratification. From 1 to 12. 

Number of Cells Number of cells (smaller in size than intervals) used for 
preliminary stratification. From 20 to 100. 

Confidence Level (1-Alpha) The level of confidence that the sample estimate is accurate 
(1 – alpha risk of incorrect rejection). 1 or 2-sided (80 to 
99%). 

Power (1-Beta) The power of the test to detect a significant difference (1 – 
beta risk of incorrect acceptance). From 50 to 99%. 

1 or 2-sided Interval 1 or 2-sided confidence interval (lower/upper tails).  
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High 100% Cutoff Upper 100% cutoff. All items above this limit are selected.  

Low 100% Cutoff Lower 100% cutoff. All items below this limit are selected. 

Expected Misstatement % Estimated proportion of misstatement in the population. 
From 0.05 to 20%. An error rate must be entered for the 
calculation. 

Tolerable Misstatement Maximum acceptable amount of monetary misstatement in 
the population. Maximum limit is 50% of population value. 

Seed A random seed value is used to generate the random values 
for the sample selection. The seed for a previous sample 
can be used to recalculate the same results for that sample. 

 

Results Description 

Stratum Sequence number for each stratum. 

Boundary The lower and upper limits (boundaries) for the stratum. 

Count Number of items or records in the stratum. 

Amount Total value of the recorded amounts in the stratum. 

Mean Average value of the recorded amounts in the stratum. 

Std Dev Standard deviation of the recorded amounts in the stratum. 

CV Coefficient of variation (ratio of the standard deviation to the mean).  

Sample The number of items or records to sample in the stratum. 

Ratio P/T Precision as a fraction of tolerable misstatement related to α and β. 

(P/T = Zα / Zα + Zβ) 

Precision Allowance for sampling risk (P/T * tolerable misstatement). 

Sample Size The total number of items to sample. Maximum size is 5000. 

 
The samples are randomly selected from each stratum based on a random seed (stratified 
random selection). 
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9.2 Evaluate Results 

Sampling > CVS > Evaluate Results 
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The sample results are evaluated by determining if the population value falls within the audited 
amount precision limits or the misstatement precision limits do not exceed the tolerable 
misstatement: 

◼ If the population value falls within the audited amount precision limits, conclude that the 
account is likely fairly stated; 

◼ If the misstatement precision limits do not exceed the tolerable misstatement, conclude that 
the account is not materially misstated; 

◼ If the lower or upper misstatement precision limit is greater than tolerable misstatement, 
conclude that the account is materially misstated. 

 
Input Values Description 

Population Value Book value or monetary value of the population. Maximum value 
of 2000 Million. 

Confidence Level (%) The desired level of confidence (1 - risk of incorrect acceptance). 
From 50 to 99%. 

Precision Limits Evaluate both precision limits (2-sided) or upper limit (1-sided) or 
lower limit (1-sided). 

Evaluation Method Estimation method to evaluate sample results (difference, ratio or 
mean-per-unit estimation). 

Strata Stratum number, total items in the stratum and population value. 
Maximum is 20 rows. 

Samples (Book/Audit 
Value) 

The book and audited values for all the samples (including the 
High 100% and Low 100% cutoff items). Maximum number of 
items is 5000. 

 
Results Description 

Stratum Sequence number for each stratum. 

Difference Non-zero differences in the sample (audited value - book value). 

Mean Difference Mean of the sample differences (misstatements / sample size). 

Sample Ratio Ratio of the sample differences (misstatements / audited 
amounts). 

Sample Mean Mean of the audited amounts (audited amounts / sample size). 

Sample Estimate Sample estimate of the misstatement or audited amount (total 
items * sample mean). 

Standard Deviation Standard deviation of the sample (measure of the variance within 
the sample). 

Standard Error Standard deviation of the sampling distribution (standard error of 
the estimate).  

Precision Allowance for sampling risk (standard error * critical T-value for 
the confidence level). 

Point Estimate: 
Audited Value 

Sample estimate of audited amounts (or population book value + 
sample estimate of misstatement). 

Point Estimate: 
Misstatement 

Sample estimate of misstatement + High 100% + Low 100%. 

Lower Limit Lower precision limit (point estimate - precision value). 
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Upper Limit Upper precision limit (point estimate + precision value). 
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10. Audit Risk Calculator 

Sampling > Audit Risk Calculator 
 

 
 

The calculation is based on the Audit Risk Model (AR = IR x CR x DR), where the audit risk 
consists of three components i.e. inherent, control and detection risks. 
 

Input Values Description 

Audit Risk (AR) The overall acceptable level of audit risk. From 1 to 5% (default at 
5%). 

Inherent Risk (IR) The susceptibility of an account balance or class of transactions to 
material misstatement, assuming there are no related controls. 
From 30 to 100%. 

Control Risk (CR) The risk that the internal controls will fail to prevent or detect 
material misstatements. From 20 to 100%. 

 
Results Description 

Detection Risk (DR) The risk that the audit procedures will fail to detect material 
misstatements. 

Substantive Assurance The assurance required from substantive tests (complement of 
detection risk i.e. 100% - DR). 

 
 

https://cplusglobal.wordpress.com/


AuditSampler v3 User Guide  https://cplusglobal.wordpress.com 

Copyright © 2019 cplusglobal   44 

11. Audit Risk Assessment Worksheet 

Sampling > Audit Risk Assessment Worksheet 
 

 
 

Input Values Description 

Account Balance / 
Class of Transactions 

The significant account balances (e.g. receivables, inventory) or 
classes of transactions (e.g. sales, purchases). 

Assertions (CEAVO) The relevant assertions for the account balance which include 
Completeness, Existence, Accuracy, Valuation and Ownership. 

Identified Risks The identified inherent and potential risks for the relevant 
assertions before considering any related controls. 

Information System The information system or IT environment used to process and 
record the financial transactions and prepare financial reports. 

Control Activities The controls related to the identified risks such as authorizations 
and approvals, reconciliations, physical or logical access controls 
to computer programs and data files, and segregation of duties. 

Audit Risk (AR) The overall acceptable level of audit risk. From 1 to 5%. 

Inherent Risk (IR) The susceptibility of an account balance or class of transactions to 
material misstatement, assuming there are no related controls. 
From 30 to 100%. 

Control Risk (CR) The risk that the internal controls will fail to prevent or detect 
material misstatements. From 20 to 100%. 

 
Results Description 

Risks of Material 
Misstatement (RMM) 

The combined inherent and control risks (RMM = IR x CR). 

Detection Risk (DR) The risk that the audit procedures will fail to detect material 
misstatements. The amount of substantive assurance required is 
the inverse of detection risk, i.e. 100% – DR. 
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12. Random Number Generator 

Sampling > Random Number Generator 
 

 
 

The random numbers are generated based on a random seed to ensure that each set of 
numbers is randomly generated. 
 

Input Values Description 

Start Value The starting value to randomly generate unique numbers. Must be 
greater than 0 and less than the end value. 

End Value The ending value to randomly generate unique numbers. Must be 
greater than the start value and not exceed 2000 Million. 

Required Sample Size The number of samples to select. Maximum size is 3000. 

Random Seed A random seed value is used to generate the random numbers for 
the sample selection. The seed for a previous sample can be used 
to recalculate the same results for that sample. 

 

Results Description 

Sort Results Determines if the results are sorted in sequential order when 
displayed. The default is not to sort the results. 
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